The Original SAMi-3 and the SAMi App are compatible with the below Apple devices.

 5th generation iPod touch running iOS 7 or newer.
297px-4th_Generation_iPod_touch.png

iPhone 4s and newer running at least iOS 7

IPhone_5s.png

iPad 3rd generation and newer running at least iOS 7

IPad_Air.png

iPad 3rd generation and newer running at least iOS 7

iPadMiniWhite.jpg

Note - if your current device is an Android or does not meet these minimum iOS specs, consider purchasing a SAMi Kit which will include a brand new 64gb iPad Mini!

Customer reviews

A few of our Partners